Get in touch
Back
Maintenance

Small Maintenance on cPanel and Free Servers

Completed 24 Feb at 08:10am +0545.

Free Hosting's CPanel Status s787 s789 s800 s801
Completed

Maintenance completed

Posted 24 Feb at 08:10am +0545.
Started

Conducting small maintenance on cPanel and free servers to improve reliability and security.

Posted 24 Feb at 07:29am +0545.