Back
Resolved
Resolved
cPanel Timeout Issue
Started 13 Nov at 06:12pm +0545, resolved 13 Nov at 06:41pm +0545.
Free Hosting's CPanel Status
Resolved
The issue is fixed now, but some users may face a timeout error sometimes due to high load. Thank you for being so patient.
Posted 13 Nov at 06:41pm +0545.
Updated
Our tech teams are working hard to restore access to cPanel. Thank you for your patience, and this issue will be resolved as soon as possible.
Posted 13 Nov at 06:24pm +0545.
Created
cPanel is temporarily unavailable for a small percentage of users. This issue is related to our internal service, and we're actively working on resolving it. The dashboard will be accessible again very soon.
Posted 13 Nov at 06:12pm +0545.