Get in touch
Back
Downtime

Free cPanel Time-out !

Started , resolved .

Free Hosting's CPanel Status
Resolved

The problem has been resolved. Thank you for your patience.

Posted .
Updated

We have identified the root cause of the issue. It will be resolved within 10-30 minutes. Thanks for your patience!

Posted .
Created

We are experiencing some cPanel timeout problems with some users. We are checking into this and have already reported the issue to our technical team. They will get back to you as soon as possible.

Posted .