Back
Maintenance

Scheduled maintenance
Completed 15 May at 01:00am +0545.
Free Hosting's CPanel Status
Paid Hosting Client Area
s1321
s787
s789
s800
s801
Completed
Maintenance completed
Posted
15 May at 01:00am +0545.

Started
This maintenance is essential to improve performance and stability. We’ll work to keep downtime as short as possible.
Posted
15 May at 12:00am +0545.