Get in touch
Back
Maintenance

cPanel Maintenance Notice

Completed 5 Mar at 12:00pm +0545.

Free Hosting's CPanel Status
Completed

Maintenance completed

Posted 5 Mar at 12:00pm +0545.
Started

Please be informed that scheduled maintenance is planned for cPanel. Temporary service interruptions may occur.

Posted 5 Mar at 11:15am +0545.