Get in touch
Back
Maintenance

Free's CPanel Maintenance !

Completed 6 Nov at 07:49pm +0545.

Free Hosting's CPanel Status
Completed

Maintenance is done, and The cpanel is now live. Please feel free to contact us if you face any problems with cPanel. Thank you.

Posted 6 Nov at 07:49pm +0545.
Started

We are making minor changes to the Free's cPanel, so please bear with us. I appreciate your patience.

Posted 6 Nov at 07:36pm +0545.