Get in touch
Back
Maintenance

Mail Server Re-configuration !

Completed 21 Jun at 01:00am +0545.

Completed

Maintenance completed

Posted 21 Jun at 01:00am +0545.
Started

We are currently making some configurations to our mail server. As a result, some of our emails may not be functional, including info, noreply, sales, onlinesupport, technical, billing, and domains etc. However, this maintenance does not affect any of our servers and websites.

Posted 21 Jun at 12:00am +0545.