Get in touch
Back
Maintenance

DNS Re-configuration

Completed 16 Jun at 05:10pm +0545.

Main Website Free Hosting's CPanel Status s787 s789 s800 s801
Completed

Maintenance completed

Posted 16 Jun at 05:10pm +0545.
Started

We are currently performing minor DNS maintenance on our DNS router. Please stay connected.

Posted 16 Jun at 05:00pm +0545.