Get in touch
Back
Maintenance

Client & Dashboard Interface Upgrading !!

Completed 30 Apr at 08:35pm +0545.

Main Website Free Hosting's CPanel Status
Completed

Maintenance completed

Posted 30 Apr at 08:35pm +0545.
Started

We are planning to upgrade our client area and dashboard interface. None of our servers are affected by this upgrade. All data is safe.

Posted 30 Apr at 08:15pm +0545.