Get in touch
Back
Downtime

Webpage Updates !!

Started 21 Nov at 01:26pm +0545, resolved 21 Nov at 01:37pm +0545.

Main Website
Resolved

The main website upgrades have been completed, and the main website is now back online.

Posted 21 Nov at 01:37pm +0545.
Created

We are performing a small update on our main website. Client Area was not affected by this update. And your data are safe. We are just changing some things in design.

Posted 21 Nov at 01:26pm +0545.